Forum speed

  • Is it just me or has the forum been very slow sometimes in the last days? It's not always, but when it is, it's the same in various browsers and also when I access it from my phone, so it can't be a problem with my computer.


    Anyone else observe this? ?(

  • Is it just me or has the forum been very slow sometimes in the last days? It's not always, but when it is, it's the same in various browsers and also when I access it from my phone, so it can't be a problem with my computer.


    Anyone else observe this? ?(


    Only once two days ago, but nothing really serious. I have had no problems recently.

  • Just now it is terrible, every site within the forum takes ages to load ;(
    Again, it's in all browsers and both from the phone and the computer, so I have no idea what the reason could be...it has been like this for 3-4 days but not always, especially in the evenings though...

  • Just now it is terrible, every site within the forum takes ages to load ;(
    Again, it's in all browsers and both from the phone and the computer, so I have no idea what the reason could be...it has been like this for 3-4 days but not always, especially in the evenings though...


    As obvious as it may sound, run an anti-virus check. Either that or check your internet connection. The forum and the website are both quite OK.

  • The strange thing is that it's not all the time. Right now it works fine for example, and earlier all other websites except here have been fine, that's why I thought it can't be just me...I thought maybe it was because many users were online during WCH matches ;(